Back to overview
Downtime
Partial outage
Oct 01 at 08:00pm HDT
Affected services
speekl.com
Resolved
Oct 01 at 09:00pm HDT
We’re back! Servers should be up and running. Thanks for bearing with us.
Affected services
speekl.com
Created
Oct 01 at 08:00pm HDT
We’re having some trouble with our servers. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services
speekl.com